post h1 Aggiornamenti completi per la versione 3.1 di OpenOffice disponibili nei repository ufficiali di Ubuntu 9.04 Jaunty Jackalope ~ Ubuntulandiapost h1

ottobre 04, 2009

Aggiornamenti completi per la versione 3.1 di OpenOffice disponibili nei repository ufficiali di Ubuntu 9.04 Jaunty Jackalope

| No comment
Disponibili nei repository ufficiali di Canonical gli aggiornamenti completi per la nuova versione 3.1 di OpenOffice la nota suite per l'ufficio e la produttività.

Come al solito potete scaricarla automaticamente attivando l'apposita funzione.

Se volete farlo manualmente il mitico sudo ci da una mano:

Dal messaggio di notifica dell'aggiornamento disponibile scaricare il pacchetto

OOo_3.1.1_LinuxIntel_install_it_deb.tar.gz;

Il pacchetto può essere scaricato anche dalla sezione Download del Progetto Italiano OpenOffice.org cliccando sul link Versione Linux Deb.
Decomprimere l'archivio dei pacchetti di installazione: dal File Manager (Nautilus) cliccare con ill pulsante destro sull'archivio e selezionare 'Estrai qui'; oppure, da terminale, posizionarsi nella cartella che contiene l'archivio scaricato e digitare:

tar -zxvf OOo_3.1.1_LinuxIntel_install_it_deb.tar.gz

verrà creata la cartella dei pacchetti di installazione 'OOO310_m19_native_packed-1_it.9420'; spostarsi nella sotto-cartella DEBS:

cd OOO310_m19_native_packed-1_it.9420/DEBS/

infine installare i nuovi pacchetti eseguendo il comando:

sudo dpkg -i *.deb

I cambiamenti riportati dal sito ufficiale sono:

Versione 1:3.0.1-9ubuntu3.1:

* SECURITY UPDATE: fix integer underflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTDelete to
properly validate the number of columns
- CVE-2009-0200
* SECURITY UPDATE: fix buffer overflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTInsert to
properly validate the number of columns
- CVE-2009-0201
* patches/dev300/apply: create Security section and add
sw.safe_tdelete_tinsert.diff

This package contains libdba, a common library of the OpenOffice.org suite used by Base, Writer and Calc. If you need full Base functionality (or actual database drivers), please install openoffice.org-base.

Versione 1:3.0.1-9ubuntu3.1:

* SECURITY UPDATE: fix integer underflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTDelete to
properly validate the number of columns
- CVE-2009-0200
* SECURITY UPDATE: fix buffer overflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTInsert to
properly validate the number of columns
- CVE-2009-0201
* patches/dev300/apply: create Security section and add
sw.safe_tdelete_tinsert.diff

This package contains the spreadsheet component for OpenOffice.org.

Versione 1:3.0.1-9ubuntu3.1:

* SECURITY UPDATE: fix integer underflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTDelete to
properly validate the number of columns
- CVE-2009-0200
* SECURITY UPDATE: fix buffer overflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTInsert to
properly validate the number of columns
- CVE-2009-0201
* patches/dev300/apply: create Security section and add
sw.safe_tdelete_tinsert.diff

This package contains the architecture-independent files of OpenOffice.org.


Versione 1:3.0.1-9ubuntu3.1:

* SECURITY UPDATE: fix integer underflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTDelete to
properly validate the number of columns
- CVE-2009-0200
* SECURITY UPDATE: fix buffer overflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTInsert to
properly validate the number of columns
- CVE-2009-0201
* patches/dev300/apply: create Security section and add
sw.safe_tdelete_tinsert.diff

This package contains the architecture-dependent core files of OpenOffice.org.
See the openoffice.org package for more information.

Versione 1:3.0.1-9ubuntu3.1:

* SECURITY UPDATE: fix integer underflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTDelete to
properly validate the number of columns
- CVE-2009-0200
* SECURITY UPDATE: fix buffer overflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTInsert to
properly validate the number of columns
- CVE-2009-0201
* patches/dev300/apply: create Security section and add
sw.safe_tdelete_tinsert.diff

This package contains the drawing component for OpenOffice.org.

Versione 1:3.0.1-9ubuntu3.1:

* SECURITY UPDATE: fix integer underflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTDelete to
properly validate the number of columns
- CVE-2009-0200
* SECURITY UPDATE: fix buffer overflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTInsert to
properly validate the number of columns
- CVE-2009-0201
* patches/dev300/apply: create Security section and add
sw.safe_tdelete_tinsert.diff

This package contains a component which allows OpenOffice.org to "mail merge" to E-Mail.

Versione 1:3.0.1-9ubuntu3.1:

* SECURITY UPDATE: fix integer underflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTDelete to
properly validate the number of columns
- CVE-2009-0200
* SECURITY UPDATE: fix buffer overflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTInsert to
properly validate the number of columns
- CVE-2009-0201
* patches/dev300/apply: create Security section and add
sw.safe_tdelete_tinsert.diff

This package contains the GNOME VFS support and a GConf backend. You can extend the functionality of this by installing these packages:
* openoffice.org-evolution: Evolution addressbook support
* evolution

Versione 1:3.0.1-9ubuntu3.1:

* SECURITY UPDATE: fix integer underflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTDelete to
properly validate the number of columns
- CVE-2009-0200
* SECURITY UPDATE: fix buffer overflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTInsert to
properly validate the number of columns
- CVE-2009-0201
* patches/dev300/apply: create Security section and add
sw.safe_tdelete_tinsert.diff

This package contains the Gtk plugin for drawing OOo's widgets with Gtk+ and a Gtk/GNOMEish File Picker when running under GNOME. It also contains a QuickStarter for the "notification area".

Versione 1:3.0.1-9ubuntu3.1:

* SECURITY UPDATE: fix integer underflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTDelete to
properly validate the number of columns
- CVE-2009-0200
* SECURITY UPDATE: fix buffer overflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTInsert to
properly validate the number of columns
- CVE-2009-0201
* patches/dev300/apply: create Security section and add
sw.safe_tdelete_tinsert.diff

This package contains the presentation component for OpenOffice.org.

Versione 1:3.0.1-9ubuntu3.1:

* SECURITY UPDATE: fix integer underflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTDelete to
properly validate the number of columns
- CVE-2009-0200
* SECURITY UPDATE: fix buffer overflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTInsert to
properly validate the number of columns
- CVE-2009-0201
* patches/dev300/apply: create Security section and add
sw.safe_tdelete_tinsert.diff

This package contains the equation editor component for OpenOffice.org.

Versione 1:3.0.1-9ubuntu3.1:

* SECURITY UPDATE: fix integer underflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTDelete to
properly validate the number of columns
- CVE-2009-0200
* SECURITY UPDATE: fix buffer overflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTInsert to
properly validate the number of columns
- CVE-2009-0201
* patches/dev300/apply: create Security section and add
sw.safe_tdelete_tinsert.diff






This package contains the "human" symbol style, default style for Ubuntu.

Versione 1:3.0.1-9ubuntu3.1:

* SECURITY UPDATE: fix integer underflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTDelete to
properly validate the number of columns
- CVE-2009-0200
* SECURITY UPDATE: fix buffer overflow via crafted Word Document
- patches/dev300/sw.safe_tdelete_tinsert.diff: adjust sprmTInsert to
properly validate the number of columns
- CVE-2009-0201
* patches/dev300/apply: create Security section and add
sw.safe_tdelete_tinsert.diff

This package contains the wordprocessor component for OpenOffice.org.

Altre idee:

a) Per rimuovere la versione vecchia ed installare quella nuova:

Se volete usare il terminale l'operazione di rimozione è più veloce. Basta aprire il terminale ed incollare il comando:

sudo apt-get remove openoffice*.*

b) Per verificare ed installare gli aggiornamenti:

sudo apt-get update
sudo apt-get upgrade

Nelle ultime releases di Ubuntu il processo è automatizzato, quindi abbastanza semplice.


Se ti è piaciuto l'articolo , iscriviti al feed cliccando sull'immagine sottostante per tenerti sempre aggiornato sui nuovi contenuti del blog:

Ultimi post pubblicati

Dark Orbit    300x250

Get Chitika | Premium

Universo Linux



, ,

Nessun commento:

Posta un commento

Caricamento in corso...

Ultimi post pubblicati

Archivio

Ubuntulandia in Instagram

>center>

Post Più Popolari